[Fixed] Joomla 3.x Error with Jaliro Plugin and Glossary component

When you upgrade to joomla 3.x or new installation Joomla 3.x with Glossary free component from remository.com you will get messages like that:

Sorry, this version of Glossary requires PHP version 5.2.3 or later

and/or

Sorry, this version of Glossary requires the Jaliro plugin to be installed and active.

Joomla Red Background

So what is Jaliro Joomla plugin?

The Jaliro Plugin provides an advanced software platform for the newest versions of Glossary. It must be installed before installing Glossary 2.8.x for Joomla 3.x. Affter installed the Jaliro Plugin, you must go to admin menu Extensions -> Plugins find and active Jaliro plugin.

Jaliro Plugin Error

Now we can new fresh installation Glossary component – Extensions -> Manage -> Upload & Install Joomla Extension

Upload Package Glossary

Fatal error: Call to undefined method JLoader::applyAliasFor() in /public_html/YOUR_DIRECTORY/libraries/ClassLoader.php on line 45 or Joomla admin became blank page affter installed the Glossary component, don’t worries. Login to your FTP or hosting controlpanel and go to /public_html/libraries/cms/class. Open file loader.php with your editor like notepade or notepade pluss

Find LoadClass

Find if($class){JLoader::applyAliasFor($class);}
Replace with: //if($class){JLoader::applyAliasFor($class);}
Save your file.

Done.

If you have any questions: please contact to Lamvt: http://gotiengviet.com.vn/ or http://glodeco.com.vn/lien-he/

You may also like...

Leave a Reply